升级macOS 13 Ventura 系统后打开应用软件提示已损坏,无法打开/安全策略”已设为“宽松安全性的解决方法

刚升级 macOS 13 Ventura 的小伙伴运行 App 会提示提示【xxx已损坏,无法打开】、【无法打开“xxx”,因为“安全策略”已设为“宽松安全性”】,这是由于升级到13系统的安全选项被重置了。下面就教大家如何修复。

常见的几种报错

  • xxx软件已损坏,无法打开
  • 无法打开“xxx”,因为“安全策略”已设为“宽松安全性”

一、xxx软件已损坏,无法打开

1、强制打开

前往 设置—隐私与安全性—安全性(在设置最下面)—“强制打开已拦截的xxxx.app”

2、开启任何来源

1)依次打开系统偏好设置>安全与隐私>通用,如果没有打开任何来源选项,点击左下角的小黄锁并激活,然后选择任何来源并锁定即可。

2)如果没有出现任何来源,那么打开终端输入以下代码然后回车并输入密码再回车即可开启。(全部复制以下代码)

sudo spctl --master-disable

再次打开系统偏好设置>安全与隐私>通用就会发现已经启用任何来源选项了,如果没有开启激活选择即可。不过一般执行完命令后就默认选择了。

3、签名修复

终端输入以下代码,然后拖到软件到终端回车并输入密码再回车即可。(全部复制以下代码)

sudo xattr -rd com.apple.quarantine 

4、再次修复

修复之后,进入应用程序右键打开软件,如果还是提示已损坏就在终端输入以下代码,然后拖到软件到终端回车并输入密码再回车即可。(全部复制以下代码)

sudo codesign --sign - --force --deep 

二、无法打开“xxx”,因为“安全策略”已设为“宽松安全性”

1、在“恢复” App 中,选取“实用工具”>“启动安全性实用工具”。

2、选择要用来设定安全策略的系统。

3、如果磁盘已使用文件保险箱加密,请点按“解锁”,输入密码,然后点按“解锁”。

4、点按“安全策略”。

5、检查以下安全性选项:

完整安全性:确保只有当前的操作系统或者当前 Apple 信任的签名操作系统软件才能运行。此模式在安装软件时需要网络连接。

降低安全性:允许运行 Apple 信任过的任何版本的签名操作系统软件。

6、如果需要,请选择“降低安全性”,输入管理员用户名和密码,然后执行以下一项操作:

选择“允许用户管理来自被认可开发者的内核扩展”复选框以允许使用旧版内核扩展的软件进行安装。

选择“允许远程管理内核扩展和软件自动更新”复选框以授权使用移动设备管理 (MDM) 解决方案远程管理旧版内核扩展和软件更新。

7、点按“好”。

8、重新启动 Mac 以使更改生效。

喜欢就支持一下吧
点赞0赞赏 分享
评论 共2条
头像
macOS请先附上系统版本和芯片;macOS有问题/报错直接搜索教程;请组织好语言再说出发生的问题及原因。
提交
头像

昵称

取消
昵称常用语表情代码